Delphi 2010手动安装indy10.5.7

由于老版本的Indy对ssl支持有问题,好像是某些不支持,同样的代码,安装了新版Indy10.5.7就可以完美运行,但是indy 10.2.5,indy 9就不行,欧卖疙瘩。前一篇鸟语你看懂了没有?我研究了大半天,安装了好几次,始终没有成功,老是报错,相当郁闷。最后还是按照老办法安装成功。

经过本人实践得真理:以下安装适合Delphi7,Delphi2006,Delphi2007 安装Indy组件,由于默认安装开始工具后,自带了Indy组件,但是都是低版本的,要安装最新版的Indy只有自己安装。

具体步骤如下:

        1、删除delphi目录Bin下的indy*.BPL文件,这是官方旧版本的文件,放心删除(你不放心可以做备份)。

2、删除delphi目录下的 Id*.DCU文件,一般都是在lib目录里。

delphi2010  lib目录下面有一个indy10的文件夹,直接删除就可以了。另外确保万无一失,查看一下系统system32 目录有没有id***.bpl的文件,有的话也删除。

3、把搜索目录加上:主要添加indy10\LIB路径下的System、Core、Protocols下的三个目录(如图)。

library路径.jpg

      4、打开安装目录下的indy10\lib目录,安装DPK包顺序如下:

(1)编译 System\IndySystem140.dpk

(2)编译 Core\IndyCore140.dpk,编译安装Core\dclIndyCore140.dpk(设计包)

(3)编译 Protocols\IndyProtocols140.dpk,编译安装Protocols\dclIndyProtocols140.dpk(设计包)

5、安装完毕。

安装indy10.5.7.jpg

Posted in 软件开发 by 傻猫 at August 16, 2010.
Tags: delphi, delphi2010, Indy10, indy, indy10安装

已有 3 条评论 »

  1. Ev1n

    先下手为强,光脚窜门来了

    8.0升了没

    1. Ev1n

      我的版本是与SVN同步的,只要有最新的更新,马上升级。哈哈

      1. Ev1n

        请教一下。SVN版本是 下载下来直接替换还是要按上面的步骤卸载后重新安装呢

添加新评论